Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-54084

Src package README: Qt 5.7 requires C++11

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.7.0
    • Fix Version/s: 5.7.1
    • Component/s: Packaging & Installer
    • Labels:
      None

      Description

      From README in qt-everywhere-enterprise-src-5.7.0:

      System Requirements:
      [...]
          - C++ compiler supporting the C++98 standard
      

      Qt 5.8 now requires C++11.

      Furthermore:

      • remove mentioning of QtWebKit.
      • Update Windows requiremnets: Windows SDK 7.1 IIRC uses the VIseual STudio 2010 compiler, which is not supported anymore

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              releaseteam Qt Release Team
              Reporter:
              kkohne Kai Köhne
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes