Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-92880

TLS 1.0 and 1.1 are due for deprecation

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 6.2
    • Fix Version/s: 6.3.0 Alpha
    • Component/s: Network: SSL
    • Labels:
      None

      Description

      They've long since been superseded by 1.2 and 1.3 has also released since.

      The best practice RFC is linked below.

      RFC 8996 - Deprecating TLS 1.0 and TLS 1.1 (ietf.org)

      We should drop 1.0 and 1.1 from SecureProtocol and deprecate the enum values. 6.2 put as preliminary version, but we could also wait until 6.3 to let them stay undeprecated in the first Qt 6 LTS.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            manordheim Mårten Nordheim
            Reporter:
            manordheim Mårten Nordheim
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes