Uploaded image for project: 'Qt Creator'
  1. Qt Creator
  2. QTCREATORBUG-14038

ClangCodeModel plugin cannot be loaded

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: Qt Creator 3.1.1
    • Component/s: All Other Issues
    • Labels:
      None
    • Environment:
      OS X 10.10.3, Qt 5.4.1 (online installer), Qt Creator 3.3.1

      Description

      An error on startup after upgrade to Qt 5.4.1 / Qt Creator 3.1.1:

      The following plugins have errors and cannot be loaded:
      ClangCodeModel
      
      Details:
      /Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libClangCodeModel.dylib: Cannot load library /Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libClangCodeModel.dylib: (dlopen(/Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libClangCodeModel.dylib, 5): Library not loaded: @rpath/libclang.dylib
        Referenced from: /Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libClangCodeModel.dylib
        Reason: image not found)
      
      $ otool -L "/Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libClangCodeModel.dylib"
      /Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libClangCodeModel.dylib:
      	@rpath/PlugIns/libClangCodeModel.dylib (compatibility version 0.0.0, current version 0.0.0)
      	@rpath/PlugIns/libCore.dylib (compatibility version 0.0.0, current version 0.0.0)
      	@rpath/PlugIns/libCppTools.dylib (compatibility version 0.0.0, current version 0.0.0)
      	@rpath/PlugIns/libTextEditor.dylib (compatibility version 0.0.0, current version 0.0.0)
      	@rpath/PlugIns/libProjectExplorer.dylib (compatibility version 0.0.0, current version 0.0.0)
      	@rpath/Frameworks/libCPlusPlus.1.dylib (compatibility version 1.0.0, current version 1.0.0)
      	@rpath/Frameworks/libAggregation.1.dylib (compatibility version 1.0.0, current version 1.0.0)
      	@rpath/Frameworks/libExtensionSystem.1.dylib (compatibility version 1.0.0, current version 1.0.0)
      	@rpath/Frameworks/libQtcSsh.1.dylib (compatibility version 1.0.0, current version 1.0.0)
      	@rpath/Frameworks/libUtils.1.dylib (compatibility version 1.0.0, current version 1.0.0)
      	@rpath/Frameworks/libLanguageUtils.1.dylib (compatibility version 1.0.0, current version 1.0.0)
      	@rpath/libclang.dylib (compatibility version 1.0.0, current version 0.0.0)
      	@loader_path/../Frameworks/QtWidgets.framework/Versions/5/QtWidgets (compatibility version 5.4.0, current version 5.4.1)
      	@loader_path/../Frameworks/QtGui.framework/Versions/5/QtGui (compatibility version 5.4.0, current version 5.4.1)
      	@loader_path/../Frameworks/QtCore.framework/Versions/5/QtCore (compatibility version 5.4.0, current version 5.4.1)
      	/System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration (compatibility version 1.0.0, current version 1.0.0)
      	/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
      	@loader_path/../Frameworks/QtConcurrent.framework/Versions/5/QtConcurrent (compatibility version 5.4.0, current version 5.4.1)
      	@loader_path/../Frameworks/QtNetwork.framework/Versions/5/QtNetwork (compatibility version 5.4.0, current version 5.4.1)
      	/System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0)
      	/System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility version 1.0.0, current version 1.0.0)
      	/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 120.0.0)
      	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1213.0.0)
      
      $ otool -L "/Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libclang.dylib"
      /Users/jpnurmi/Qt/Qt Creator.app/Contents/PlugIns/libclang.dylib:
      	@rpath/libclang.dylib (compatibility version 1.0.0, current version 0.0.0)
      	/usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.5)
      	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 169.3.0)
      	/usr/lib/libncurses.5.4.dylib (compatibility version 5.4.0, current version 5.4.0)
      	/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 56.0.0)
      

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                con Eike Ziller
                Reporter:
                jpnurmi J-P Nurmi
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes