Uploaded image for project: 'Qt Mobility'
  1. Qt Mobility
  2. QTMOBILITY-2034

Magnetometer not working properly on N8 running Belle

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.1.2
    • Fix Version/s: None
    • Component/s: Sensors
    • Labels:
      None
    • Environment:
      N8, Belle, Qt 4.7.4

      Description

      I made Qt application which collects data from sensors (accelerometer, magnetometer, proximity, compass, GPS...). I have used application on N8 and it works perfectly on Anna devices. However, there seems to be problem with Belle. It works fine at start (from 5 to 60 minutes) but in some point magnetometers and compass seem to freeze, and I do not get updates to their values. This problem seems to be related with Belle because it works fine on Anna and I've tested the application with two different N8 phones running Belle.

      Update: Build using Qt 4.7.4 for Anna and Qt 4.7.4 for Belle, neither works

      Update 2: Magnetometer seems to freeze faster under battery save mode

        Attachments

        1. Magnetometri.pro
          1 kB
        2. Magnetometri.sis
          13 kB
        3. main.cpp
          0.3 kB
        4. mainwindow.cpp
          3 kB
        5. mainwindow.h
          0.9 kB
        6. mainwindow.ui
          0.9 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            satu.m.makela satu makela
            Reporter:
            pekkeli Pekka Siirtola
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes