Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-29579

QtWebkit from Qt5 couldn't display Chinese characters correctly on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Cannot Reproduce
    • Affects Version/s: 5.0.0
    • Fix Version/s: None
    • Component/s: WebKit
    • Labels:
    • Environment:
      MS Windows 7 64bit, MSVC2010

      Installer 362

      Description

      I built Qt5 from Git with MSVC2010 SP1 by myself, I used ICU5.0 to build QtWebkit. But I found it couldn't display Chinese characters correctly on Windows, the official example under qt5\qtwebkit-examples-and-demos\examples\browser has the same issue. Yes, I checked this issue on Windows 7, Mac OSX 10.6.8 and Ubuntu 12.10, only Windows version has this problem. Someone has reported this issue before but got no reply. https://qt-project.org/forums/viewthread/21022 .

        Attachments

        1. chineseBrowser362_qt.png
          chineseBrowser362_qt.png
          192 kB
        2. chineseBrowser362.png
          chineseBrowser362.png
          213 kB
        3. webkit-issue1.png
          webkit-issue1.png
          334 kB
        4. webkit-issue-official-browser.png
          webkit-issue-official-browser.png
          179 kB
        For Gerrit Dashboard: QTBUG-29579
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            ntg Pierre Rossi
            Reporter:
            missdeer Yang Fan
            Votes:
            1 Vote for this issue
            Watchers:
            8 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes