Uploaded image for project: 'Qt Automotive Suite'
  1. Qt Automotive Suite
  2. AUTOSUITE-560

Building neptune3 against the Qt from the automotive installer is not possible

    XMLWordPrintable

    Details

      Description

      Trying to build the neptune3 executable fails with the following error:

      11:43:32: The process "C:\QtAS\5.11.0\msvc2017_64\bin\qmake.exe" exited normally.
      
      11:43:32: Starting: "C:\QtAS\Tools\QtCreator\bin\jom.exe" qmake_all
      
      
      
      
      jom 1.1.2 - empower your cores
      
      
      
      
      11:43:32: The process "C:\QtAS\Tools\QtCreator\bin\jom.exe" exited normally.
      
      11:43:32: Starting: "C:\QtAS\Tools\QtCreator\bin\jom.exe"
      
      C:\QtAS\Tools\QtCreator\bin\jom.exe -f Makefile.Release
      
      link /NOLOGO /DYNAMICBASE /NXCOMPAT /INCREMENTAL:NO /SUBSYSTEM:CONSOLE "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' publicKeyToken='6595b64144ccf1df' language='*' processorArchitecture='*'" /MANIFEST:embed /OUT:C:\work\build-neptune3-ui-Desktop_Qt_5_11_0_MSVC2017_64bit-Release\neptune3-ui.exe @C:\Users\QtUser\AppData\Local\Temp\neptune3-ui.exe.2672.16.jom
      
      LINK : fatal error LNK1181: cannot open input file 'c:\Users\qt\work\install\lib\Qt5Quick.lib'
      
      jom: C:\work\build-neptune3-ui-Desktop_Qt_5_11_0_MSVC2017_64bit-Release\src\neptune3-ui\Makefile.Release [C:\work\build-neptune3-ui-Desktop_Qt_5_11_0_MSVC2017_64bit-Release\neptune3-ui.exe] Error 1181
      
      jom: C:\work\build-neptune3-ui-Desktop_Qt_5_11_0_MSVC2017_64bit-Release\src\neptune3-ui\Makefile [release] Error 2
      
      11:43:32: The process "C:\QtAS\Tools\QtCreator\bin\jom.exe" exited with code 2.
      
      Error while building/deploying project neptune3-ui (kit: Desktop Qt 5.11.0 MSVC2017 64bit)
      
      When executing step "Make"
      
      11:43:32: Elapsed time: 00:02.
      

       

      Looking into it, it seems like the prl files for all appman libs contain broken linker options. E.g. Qt5AppManMaind.prl looks like this:

      QMAKE_PRO_INPUT = main-lib.pro
      QMAKE_PRL_TARGET = Qt5AppManMaind.lib
      QMAKE_PRL_CONFIG = lex yacc debug exceptions depend_includepath testcase_targets import_qpa_plugin windows qt_build_extra file_copies qmake_use qt warn_on link_prl flat debug_and_release precompile_header autogen_precompile_source embed_manifest_dll embed_manifest_exe no_plugin_manifest win32 msvc copy_dir_files sse2 aesni sse3 ssse3 sse4_1 sse4_2 avx avx2 avx512f avx512bw avx512cd avx512dq avx512er avx512pf avx512vbmi compile_examples f16c force_debug_info largefile precompile_header rdrnd shani x86SimdAlways prefix_build force_independent utf8_source create_prl link_prl prepare_docs qt_docs_targets no_private_qt_headers_warning QTDIR_build qt_example_installs testcase_exceptions done_config_libarchive done_config_libyaml done_config_touchemulation debug DebugBuild Debug build_pass c+11 debug DebugBuild Debug build_pass link_pkgconfig hide_symbols exceptions static internal_module relative_qt_rpath git_build qmake_cache target_qt c11 strict_c+ qt_install_headers need_fwd_pri qt_install_module debug_and_release build_all skip_target_version_ext debug DebugBuild Debug build_pass have_target staticlib no_plist exclusive_builds debug_info no_autoqmake thread opengl dbusadaptors dbusinterfaces moc resources
      QMAKE_PRL_VERSION = 5.11.0
      QMAKE_PRL_LIBS = -LC:\\openssl
      lib -LC:\\Utils\\my_sql\\my_sql
      lib -LC:\\Utils\\postgresql\\pgsql
      lib -luser32 -L$$[QT_INSTALL_LIBS] -Lc:/Users/qt/work/install/lib $$[QT_INSTALL_LIBS]
      Qt5AppManDBusd.lib $$[QT_INSTALL_LIBS]
      Qt5AppManInstallerd.lib $$[QT_INSTALL_LIBS]
      Qt5AppManPackaged.lib $$[QT_INSTALL_LIBS]
      Qt5AppManCryptod.lib -ladvapi32 $$[QT_INSTALL_LIBS]
      qtarchived.lib -lcrypt32 $$[QT_INSTALL_LIBS]
      Qt5AppManMonitord.lib $$[QT_INSTALL_LIBS]
      Qt5AppManSharedMaind.lib $$[QT_INSTALL_LIBS]
      Qt5AppManWindowd.lib $$[QT_INSTALL_LIBS]
      Qt5AppManManagerd.lib $$[QT_INSTALL_LIBS]
      Qt5AppManPluginInterfacesd.lib $$[QT_INSTALL_LIBS]
      Qt5AppManApplicationd.lib $$[QT_INSTALL_LIBS]
      Qt5AppManNotificationd.lib $$[QT_INSTALL_LIBS]
      Qt5AppManCommond.lib $$[QT_INSTALL_LIBS]
      qtyamld.lib c:/Users/qt/work/install/lib
      Qt5Quickd.lib c:/Users/qt/work/install/lib
      Qt5Qmld.lib c:/Users/qt/work/install/lib
      Qt5Networkd.lib c:/Users/qt/work/install/lib
      Qt5Guid.lib c:/Users/qt/work/install/lib
      Qt5Concurrentd.lib c:/Users/qt/work/install/lib
      Qt5DBusd.lib c:/Users/qt/work/install/lib
      Qt5Cored.lib
      

       

      It uses $$[QT_INSTALL_LIBS] for all internal dependencies, but contains a broken path to all Qt dependencies

        Attachments

        For Gerrit Dashboard: AUTOSUITE-560
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            sapiippo Samuli Piippo
            Reporter:
            gagi Dominik Holland
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes