Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-1191

build of pyside2 fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Fixed
    • Affects Version/s: 5.14.0
    • Fix Version/s: 5.14.1
    • Component/s: Build System
    • Labels:
      None
    • Platform/s:
      Linux/X11
    • Commits:
      e1c45ef7c0e453a6df4e83932317b48dbaad3c6f (pyside/pyside-setup/5.14.1)

      Description

      hello,
      I'm trying to package pyside2 5.14 for VoidLinux distribution.

      It miserably fails on creating build/PySide2/QtCore.so:
      undefined symbol: _ZN18QMessageLogContext4copyERKS

      symbol generated in PySide2/QtCore/CMakeFiles/QtCore.dir/PySide2/QtCore/qmessagelogcontext_wrapper.cpp.o

      First of all, does pyside2 5.14.0 supports Qt 5.13.2 ? or pyside2 version has to have a lower/equal version of Qt ?

       

        Attachments

        For Gerrit Dashboard: PYSIDE-1191
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            crmaurei Cristian Maureira-Fredes
            Reporter:
            yopito Pierre Bourgin
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes