Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-1270

Building wheels against Qt binary fails because of non-existent libQt5Pdf.so.5

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Invalid
    • Affects Version/s: 5.15.0
    • Fix Version/s: None
    • Component/s: Build System
    • Labels:
    • Platform/s:
      All

      Description

      Building pyside-setup repository (5.15 branch) against the latest 5.15.0-beta4 binary (sha: 176d9ce09c8abcc232a4bd5ebc2ac6d6413113af), building fails with:

      File "/home/mipohjan/RTA/pyside-setup/build_scripts/main.py", line 732, in run
          self.prepare_packages()
        File "/home/mipohjan/RTA/pyside-setup/build_scripts/main.py", line 1153, in prepare_packages
          return prepare_packages_posix(self, vars)
        File "/home/mipohjan/RTA/pyside-setup/build_scripts/platforms/unix.py", line 218, in prepare_packages_posix
          prepare_standalone_package_linux(self, vars)
        File "/home/mipohjan/RTA/pyside-setup/build_scripts/platforms/linux.py", line 74, in prepare_standalone_package_linux
          recursive=False, vars=vars, force_copy_symlinks=True)
        File "/home/mipohjan/RTA/pyside-setup/build_scripts/utils.py", line 352, in copydir
          raise EnvironmentError(errors)
      
        EnvironmentError: [(\'/home/mipohjan/RTA/qt5/5.15.0/gcc_64/lib/libQt5Pdf.so.5\', \'/home/mipohjan/RTA/pyside-setup/build/lib.linux-x86_64-2.7/PySide2/Qt/lib/libQt5Pdf.so.5\', "[Errno 2]
      
      
       No such file or directory: \'/home/mipohjan/RTA/qt5/5.15.0/gcc_64/lib/libQt5Pdf.so.5\'")]
      Traceback (most recent call last):
        File "setup.py", line 296, in <module>
          setup_runner.run_setup()
        File "/home/mipohjan/RTA/pyside-setup/build_scripts/setup_runner.py", line 158, in run_setup
          raise RuntimeError(msg)
      RuntimeError: 
      setup.py invocation failed with exit code: 1.
      up.py invocation was: /home/mipohjan/RTA/pyside-setup/env/bin/python setup.py bdist_wheel --reuse-build --standalone --skip-cmake --skip-make-install --only-package --build-tests --parallel=4 --verbose-build --snapshot-build --qmake=/home/mipohjan/RTA/qt5/5.15.0/gcc_64/bin/qmake --package-timestamp=1587076910 --internal-build-type=pyside2
      
      ') 
      

      QtPdf is a marketplace component and not part of Qt anymore, so also the cmake build instructions needs to be updated.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              crmaurei Cristian Maureira-Fredes
              Reporter:
              mipohjan Milla Pohjanheimo
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes