Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-1461

Need to install libopengl0 on Ubuntu to be able to use pyside6 widgets

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 6.0.0
    • Fix Version/s: 6.0.1
    • Component/s: PySide
    • Labels:
      None
    • Environment:
      Python 3.8.5, PySide6 6.0.0, Ubuntu 20.04
    • Platform/s:
      Linux/X11

      Description

      I've been able to install PySide6 without problems and successfully ran import PySide6.QtCore without issues

      However when i tried import PySide6.QtWidgets i got the following error: ImportError: libOpenGL.so.0: cannot open shared object file: No such file or directory

      To fix this i had to run sudo apt install libopengl0 -y

      ***

      (I'm not sure if this is an Ubuntu issue or a Pyside issue, but when asking in the pyside2 chat on gitter Kyle Altendorf suggested reporting this issue here)

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              crmaurei Cristian Maureira-Fredes
              Reporter:
              sunyatazero Tord Dellsén
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes