Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-1593

SyntaxError in .pyi for CheckIndexOptions class

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Affects Version/s: 6.1.1
    • Fix Version/s: 6.1
    • Component/s: PySide
    • Labels:
      None
    • Commits:
      6acc53a4e426fee336a8577581f579d6c173c7bc (pyside/pyside-setup/dev) 0695cf877bab98bc654bc264538e3a5f876fa48f (pyside/pyside-setup/6.1)

      Description

      It looks like a syntax error in QtCore.pyi was introduced in PySide 6.1.1. The class definition of CheckIndexOptions doesn't have anything inside it.

      https://github.com/python-qt-tools/qts/pull/6/checks?check_run_id=2778737128#step:11:48

      .tox/mypy-py39-pyside-6/lib/python3.9/site-packages/PySide6/QtCore.pyi:182: error: expected an indented block [syntax]
      

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            ctismer Christian Tismer
            Reporter:
            altendky Kyle Altendorf
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes