Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-265

QtMultimedia module missing Linux

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 1.2.2, dev
    • Fix Version/s: 5.6, 5.9, dev
    • Component/s: PySide
    • Labels:
    • Environment:
      Ubuntu 14.04 LTS 64-bit Python3.4 PySide 1.2.2

      Description

      The build process on Linux for PySide seems to fail to build the QtMulimedia.so. I have been trying to install PySide for Python3.4 64 bit for a couple of days now. After cross comparing with my install on Windows it seems that the build instructions that can be found on the PySide read the docs website (http://pyside.readthedocs.org/en/latest/building/linux.html) fail to create a QtMulitmedia.so file, in the dist-package/Pyside folder. Which is why the module fails to import. Upon finding this flaw I installed the binary packages from the apt-get repository and found that they were also missing the module/so file. The package I installed was (python3-pyside). This bug only seems to affect Linux as my PySide install on Python3.4 on Windows has a QtMultimedia.dll and the import statement succeeds. I attached the output from build following the instructions on the read the docs website.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              mechsin Christopher Nyland
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes