Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-356

pyside2uic of pyside-tools installs for Python 3 only

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Fixed
    • Affects Version/s: dev
    • Fix Version/s: dev
    • Component/s: PySide
    • Labels:

      Description

      I'm installing pyside2-tools in Ubuntu 16.04 using the pyside2-tools package by Thomas Pietrowski and when I do this I notice that the pyside2uic Python module gets installed on the path which should be used for Python 3... even if I only have Python 2 installed in the system.

      This causes the pyside2-uic executable to complain about not finding the pyside2uic module:

      Traceback (most recent call last): File "/usr/bin/pyside2-uic", line 28, in <module> from pyside2uic.driver import Driver ImportError: No module named pyside2uic.driver
      

      I initially contacted Thomas because I figured maybe something was wrong with his "pyside2-tools" package for Ubuntu 16.04. He, however, asked me kindly to make a bug report here instead as he suspected something was not right with the CMake files.

      As a workaround, it works fine to copy the pyside2uic Python module from /usr/lib/python3/dist-packages/ to /usr/local/lib/python2.7/dist-packages

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            fredrikaverpil Fredrik Averpil
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes