Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-512

5.6: Invalid global header generated from PySide2/global.h.in

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • P1: Critical
    • Resolution: Done
    • 5.6
    • 5.6
    • PySide
    • None
    • Linux
    • a80a6eb94433529a6d984e8ff22874f7dff48eea (pyside/5.6, 9.5.2017, 5.6)

    Description

      It seems the CMake variables Qt5X11Extras_FOUND, t5WinExtras_FOUND,
      Qt5MacExtras_FOUND are not initialized on the other platforms, causing:

      #if 0
      #  include <QtScript/QtScript>
      #endif
      
      #if 0
      #  include <QtScriptTools/QtScriptTools>
      #endif
      
      #if 
      #  include <QtWinExtras/QtWinExtras>
      #endif
      
      #if 
      #  include <QtMacExtras/QtMacExtras>
      #endif
      

      This prevents a merge 5.6->5.9 since Clang fails on this.

      Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

        Activity

          People

            ctismer Christian Tismer
            kleint Friedemann Kleint
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Gerrit Reviews

                There are no open Gerrit changes