Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-517

"pyside2uic.__version__" Empty

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P5: Not important
    • Resolution: Done
    • Affects Version/s: 5.6, dev
    • Fix Version/s: None
    • Component/s: Other
    • Labels:
      None

      Description

      The value of the pyside2uic.__version__ attribute is currently always the empty string, but should probably be a non-empty version specifier resembling '2.0.0~alpha0' (as it is for the comparable PySide2.__version__ attribute).

      Fortunately, the underlying cause appears to be a trivial typo. Line 25 of the input pyside2uic/__init__.py.in file mistakenly reads:

      __version__ = "@pyside_tools_VERSION@"
      

      ...but should instead read:

      __version__ = "@pyside2_tools_VERSION@"
      

      Alternately, you could also rename the pyside2_tools_VERSION variable declared by the top-level CMakeLists.txt file to pyside_tools_VERSION.

      I leave this difficult decision in your capable hands, hard-working PySide2 team.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              ctismer Christian Tismer
              Reporter:
              leycec Cecil Curry
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes