Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-530

QML Private API build error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.9, dev
    • Fix Version/s: 5.9
    • Component/s: PySide
    • Labels:
      None
    • Environment:
      Raspbian Jessie. Qt 5.9.0. Cmake 3.7.2

      Description

      I'm trying to build Pyside 2 on Raspbian jessie operating system. I've successfully install Qt 5.9 armhf binarys from experimental branch of debian repo, and download the code from actual pyside-setup.

      The error I get is:

       

      /home/pi/pyside-setup/pyside3d_build/py3.5-qt5.9.0-32bit-debug/pyside2/libpyside/signalmanager.cpp:64:5: error: #if with no expression
      #if
      ^
      /home/pi/pyside-setup/pyside3d_build/py3.5-qt5.9.0-32bit-debug/pyside2/libpyside/signalmanager.cpp:492:5: error: #if with no expression
      #if
      ^
      /home/pi/pyside-setup/pyside3d_build/py3.5-qt5.9.0-32bit-debug/pyside2/libpyside/signalmanager.cpp: In member function 'void PySide::SignalManager::addGlobalSlot(const char*, PyObject*)':
      /home/pi/pyside-setup/pyside3d_build/py3.5-qt5.9.0-32bit-debug/pyside2/libpyside/signalmanager.cpp:348:5: warning: 'int PySide::SignalManager::addGlobalSlotGetIndex(const char*, PyObject*)' is deprecated [-Wdeprecated-declarations]
      addGlobalSlotGetIndex(slot, callback);
      ^~~~~~~~~~~~~~~~~~~~~
      In file included from /home/pi/pyside-setup/sources/pyside2/libpyside/signalmanager.h:43:0,
      from /home/pi/pyside-setup/pyside3d_build/py3.5-qt5.9.0-32bit-debug/pyside2/libpyside/signalmanager.cpp:41:
      /home/pi/pyside-setup/sources/pyside2/libpyside/signalmanager.h:101:27: note: declared here
      PYSIDE_DEPRECATED(int addGlobalSlotGetIndex(const char* slot, PyObject* callback));
      ^
      /home/pi/pyside-setup/sources/pyside2/libpyside/pysidemacros.h:57:41: note: in definition of macro 'PYSIDE_DEPRECATED'
      #define PYSIDE_DEPRECATED(func) func __attribute__ ((deprecated))
      ^~~~
      /home/pi/pyside-setup/pyside3d_build/py3.5-qt5.9.0-32bit-debug/pyside2/libpyside/signalmanager.cpp:348:41: warning: 'int PySide::SignalManager::addGlobalSlotGetIndex(const char*, PyObject*)' is deprecated [-Wdeprecated-declarations]
      addGlobalSlotGetIndex(slot, callback);
      ^
      In file included from /home/pi/pyside-setup/sources/pyside2/libpyside/signalmanager.h:43:0,
      from /home/pi/pyside-setup/pyside3d_build/py3.5-qt5.9.0-32bit-debug/pyside2/libpyside/signalmanager.cpp:41:
      /home/pi/pyside-setup/sources/pyside2/libpyside/signalmanager.h:101:27: note: declared here
      PYSIDE_DEPRECATED(int addGlobalSlotGetIndex(const char* slot, PyObject* callback));
      ^
      /home/pi/pyside-setup/sources/pyside2/libpyside/pysidemacros.h:57:41: note: in definition of macro 'PYSIDE_DEPRECATED'
      #define PYSIDE_DEPRECATED(func) func __attribute__ ((deprecated))
      ^~~~
      make[2]: *** [libpyside/CMakeFiles/pyside2.dir/signalmanager.cpp.o] Error 1
      make[2]: *** Waiting for unfinished jobs....
      make[1]: *** [libpyside/CMakeFiles/pyside2.dir/all] Error 2
      make: *** [all] Error 2
      error: Error compiling pyside2
      
      

       

       

      There are other issues related "signalmanager.cpp" building, but it does not appear to be the same case.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            ctismer Christian Tismer
            Reporter:
            freeman Alfredo
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes