Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-605

QtWebEngineProcess not being found in standalone package on macOS

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.9
    • Fix Version/s: 5.6
    • Component/s: PySide
    • Labels:
      None
    • Commits:
      ea66a78ea73f677a9025e1482e658409cecd7e2a

      Description

      from PySide2.QtWidgets import QApplication
      from PySide2.QtWebEngineWidgets import QWebEngineView
      from PySide2.QtCore import QUrl
      
      app = QApplication([])
      view = QWebEngineView()
      view.load(QUrl("https://wiki.qt.io/PySide2"))
      view.show()
      view.page().loadFinished.connect(lambda ok: app.quit())
      app.exec_()
      
      dyld: Library not loaded: @rpath/QtWebEngineCore.framework/Versions/5/QtWebEngineCore
        Referenced from: /usr/local/lib/python3.6/site-packages/PySide2/Qt/lib/QtWebEngineCore.framework/Helpers/QtWebEngineProcess.app/Contents/MacOS/QtWebEngineProcess
        Reason: image not found
      

      Minimal example and output:
      https://github.com/fredrikaverpil/pyside2-macos/issues/9

      Build log:
      https://travis-ci.org/fredrikaverpil/pyside2-macos/jobs/335973295

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                alexandru.croitor Alexandru Croitor
                Reporter:
                cbenhagen Ben Hagen
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes