Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-610

Missing ssl support for QWebSocketServer and QWebSocket

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.6, 5.9
    • Fix Version/s: None
    • Component/s: PySide
    • Labels:

      Description

      Ssl related methods seem to have been explicitly disabled in PySide2 binding:

      https://github.com/pyside/pyside2-setup/blob/5.9/sources/pyside2/PySide2/QtWebSockets/typesystem_websockets.xml#L69

       

      Therefore, it is not possible to use a QWebSocketServer in secure mode from PySide2, even if it is supported by Qt5.

       

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              ctismer Christian Tismer
              Reporter:
              sdeverly Stephane Deverly
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:

                Gerrit Reviews

                There are no open Gerrit changes