Uploaded image for project: 'Qt for Python'
  1. Qt for Python
  2. PYSIDE-686

PySide2 WebEngine not working in QML (Windows)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Invalid
    • Affects Version/s: 5.11.0
    • Fix Version/s: None
    • Component/s: PySide
    • Labels:
      None

      Description

      Not sure if this is a bug or a missing feature but I cannot get the WebEngine working in QML with latest PySide2 dev build on Windows  (Python 3.6 32bit, PySide2-5.11.0a1.dev1528118345-5.11.1).

      > py -3 main.py
      QQmlApplicationEngine failed to load component
      file:///D:/Projekte/Python3-Qt/test/web.qml:3 module "QtWebEngine" is not installed
      
      from PySide2.QtWidgets import QApplication
      from PySide2.QtQml import QQmlApplicationEngine
      
      
      def main():
          app = QApplication([])
          engine = QQmlApplicationEngine()
          engine.load('web.qml')
          app.exec_()
      
      
      if __name__ == '__main__':
          main()
      
      import QtQuick 2.0
      import QtQuick.Window 2.0
      import QtWebEngine 1.0
      
      Window {
          width: 1024
          height: 750
          visible: true
          WebEngineView {
              anchors.fill: parent
              url: "http://www.qt.io"
          }
      }
      
      

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              crmaurei Cristian Maureira-Fredes
              Reporter:
              schlamar schlamar
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes