Details
-
Task
-
Resolution: Won't Do
-
P2: Important
-
None
-
None
-
None
Description
Rename the file context variables path and filePath to something more expressive and document them.
It should be a single variable representing the file with properties like path and filePath. This way we do not clutter the global namespace with superfluous symbols.
Something like:
currentFile.filePath // absolute file path of the current file currentFile.directoryPath // directory path of the current file