Uploaded image for project: 'Qt Safe Renderer'
  1. Qt Safe Renderer
  2. QSR-446

Consider changing QtSafeRenderer to use Qt's schema

    XMLWordPrintable

    Details

    • Type: Suggestion
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Won't Do
    • Affects Version/s: QSR 1.0
    • Fix Version/s: None
    • Component/s: Other
    • Labels:

      Description

      The Qt Automotive Suite (QtAS) currently has a feature being developed where we can showcase how the Reference UI (Neptune 3 UI) can be integrated with Qt Safe Renderer.

      However, it's not possible to build the documentation correctly because of the dependencies. If QtSafeRenderer follows Qt's Schema, then, it would be more clear.

      As, QtSafeRenderer 5.12 components would install to Qt5.12, and be available to QtAS5.12 and the docs can link to those correctly. Similarly, for 5.13, you would need the components for each module and everything would work again. If that's not changed, we get into a problem where the 5.12 needs QtSafeRenderer 1.0 and 5.13 would need 2.0 (hypothetically). But if there's no such release and the version remains on 1.0, the binaries still need to be part of Qt<5.12> or Qt<5.13>, otherwise Neptune 3 UI and its friends can't find QtSafeRenderer.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              teemu.holappa Teemu Holappa
              Reporter:
              kdpalara Kavindra Palaraja
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes