Uploaded image for project: 'Qt 3D Studio'
  1. Qt 3D Studio
  2. QT3DS-4141

StereoMode not working as expected

    XMLWordPrintable

    Details

    • Platform/s:
      Linux/Other display system, macOS

      Description

      Hi,

      this is what happens on Linux/Gnome with Intel(R) UHD Graphics 620 (Kabylake GT2) using the provided test project

      ViewerSettings.StereoModeMono:

      • Works as expected

       

      ViewerSettings.StereoModeTopBottom
      ViewerSettings.StereoModeLeftRight

      • When using .uip files as subpresentation the streamed content is already split into separate eyes. This squeezes the streamed content to half the size per eye on the final rendering (Streamed content is using 2x1/4 of total presentation size)

       

      ViewerSettings.StereoModeAnaglyphRedCyan
      ViewerSettings.StereoModeAnaglyphGreenMagenta

      • Not all layers are rendered.
      • Probably the same issue as with LeftRight / TopBottom, but could not verify

       

      If you need additional information, just let me know. Best regards!

        Attachments

          Issue Links

          For Gerrit Dashboard: QT3DS-4141
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              kagro Kaj Grönholm
              Reporter:
              petermichaelsen Peter Michaelsen
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes