Uploaded image for project: 'Qt 3D Studio'
  1. Qt 3D Studio
  2. QT3DS-4215

"GL_DEPTH_TEST" is off when objects are transparent. And "Depth Prepass" does not work for the layer.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Invalid
    • Affects Version/s: Qt 3D Studio 2.8
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Qt 3D Studio 2.8
    • Platform/s:
      Windows

      Description

      "GL_DEPTH_TEST" is off when objects are transparent. And "Depth Prepass" does not work for the layer.

        Attachments

        1. test_transparent.zip
          52 kB
        2. Depth_Prepass.PNG
          Depth_Prepass.PNG
          105 kB
        3. ob.PNG
          ob.PNG
          55 kB
        4. transparent_obj .PNG
          transparent_obj .PNG
          62 kB
        5. test_opengl_GL_DEPTH_TEST.PNG
          test_opengl_GL_DEPTH_TEST.PNG
          12 kB
        6. test_opengl_NO_GL_DEPTH_TEST.PNG
          test_opengl_NO_GL_DEPTH_TEST.PNG
          18 kB
        7. depth_write.PNG
          depth_write.PNG
          73 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            anmaatta Antti Määttä
            Reporter:
            dmitry_efimov DMITRIY EFIMOV
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes