Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-100024

qt5compat requires qtdeclarative despite it's not really required

    XMLWordPrintable

    Details

    • Commits:
      307d82ee13 (qt/qt5compat/dev) c8d8b06a44 (qt/qt5compat/6.2) 29cdb1e6dc (qt/qt5compat/6.3) c8d8b06a44 (qt/qt5compat/6.2.4) 29cdb1e6dc (qt/qt5compat/6.3.0) c8d8b06a44 (qt/qt5compat/6.2) c8d8b06a44 (qt/qt5compat/6.2) c8d8b06a44 (qt/tqtc-qt5compat/6.2)

      Description

      Try to configure Qt like that:

      git clone -b v6.2.2 --depth=1 git://code.qt.io/qt/qt5.git
      cd qt5
      perl init-repository --module-subset=qtbase,qtwayland,qtimageformats,qtsvg,qt5compat
      
      ./configure \
      	-release \
      	-force-debug-info \
      	-opensource \
      	-confirm-license \
      	-qt-libpng \
      	-qt-harfbuzz \
      	-qt-pcre \
      	-no-icu \
      	-static \
      	-dbus-runtime \
      	-nomake examples \
      	-nomake tests
      

      Result:

        Module 'qt5compat' depends on 'qtdeclarative', but qtdeclarative's
        CMakeLists.txt couldn't be found.
      
        Note: Use '-skip qt5compat' to exclude it from the build.
      

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qtbuildsystem Qt Build System Team
            Reporter:
            ilya-fedin Ilya Fedin
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes