Details

    • Type: Change Request
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Fix Version/s: 6.4.0 RC1, 6.5.0 Beta1
    • Component/s: Build System: CMake
    • Labels:
      None
    • Environment:

      MacOS 12.4
      Qt Creator 7.0.1
      Qt 6.3.0
      -DQT_ANDROID_BUILD_ALL_ABIS:BOOL=ON

    • Platform/s:
      macOS, Windows
    • Commits:
      84e22f9e82 (qt/qtbase/dev) 84e22f9e82 (qt/tqtc-qtbase/dev) a4b137adce (qt/qtbase/6.3) 39480e1841 (qt/qtbase/6.4) a4b137adce (qt/tqtc-qtbase/6.3) 39480e1841 (qt/tqtc-qtbase/6.4)

      Description

      When configuring the user multi-abi project using the Qt for Android under MacOS:

      Unable to find source-code formatter for language: txt. Available languages are: actionscript, ada, applescript, bash, c, c#, c++, cpp, css, erlang, go, groovy, haskell, html, java, javascript, js, json, lua, none, nyan, objc, perl, php, python, r, rainbow, ruby, scala, sh, sql, swift, visualbasic, xml, yaml
      Unable to find source-code formatter for language: txt. Available languages are: actionscript, ada, applescript, bash, c, c#, c++, cpp, css, erlang, go, groovy, haskell, html, java, javascript, js, json, lua, none, nyan, objc, perl, php, python, r, rainbow, ruby, scala, sh, sql, swift, visualbasic, xml, yamlCMake Warning at /Users/username/Applications/Qt/6.3.0/android_arm64_v8a/lib/cmake/Qt6/qt.toolchain.cmake:71 (message):
        The toolchain file to be chainloaded
        '/opt/android/android-ndk-r22b/build/cmake/android.toolchain.cmake' does
        not exist.
      Call Stack (most recent call first):
        /Users/username/Projects/build-QtQuickExample-Android_Qt_6_3_0_Clang_x86_64-Debug/android_abi_builds/arm64-v8a/CMakeFiles/3.23.2/CMakeSystem.cmake:6 (include)
        CMakeLists.txt:3 (project)
      CMake Error: CMake was unable to find a build program corresponding to "Ninja".  CMAKE_MAKE_PROGRAM is not set.  You probably need to select a different build tool.
      CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
      CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
      -- Configuring incomplete, errors occurred!
      

      Not only related toolchain files cannot be found (ANDROID_SDK_ROOT and ANDROID_NDK_ROOT), but CMAKE_C_COMPILER and CMAKE_CXX_COMPILER are not set too.

        Attachments

          Issue Links

          For Gerrit Dashboard: QTBUG-104013
          # Subject Branch Project Status CR V

            Activity

              People

              Assignee:
              semlanik Alexey Edelev
              Reporter:
              r.putintsev Roman Putintsev
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: