Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-104352

Warn about unsuitable CMake versions in user projects like we do during Qt build

    XMLWordPrintable

    Details

    • Type: Suggestion
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 6.2.4, 6.3.1, 6.4.0 Beta1
    • Fix Version/s: None
    • Component/s: Build System: CMake
    • Labels:
      None

      Description

      When doing a Qt build, if an unsuitable CMake version is detected, we issue a warning.

      We might want to consider issuing some of these warnings when a Qt package is used in user project.
      Only some, because not all might be relevant for user projects.
      An example would be any AUTOGEN related issue in upstream CMake.

      We'd also want to provide an opt-out, in case users can't update the CMake version they are using.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            qtbuildsystem Qt Build System Team
            Reporter:
            alexandru.croitor Alexandru Croitor
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Gerrit Reviews

                There are no open Gerrit changes