Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-104373

[REG: 6.2->6.3] qt_add_qml_module does not register QML_ELEMENT classes if version starts with 0

    XMLWordPrintable

    Details

    • Commits:
      9225723a31 (qt/qtdeclarative/dev) 9225723a31 (qt/tqtc-qtdeclarative/dev) 648eece174 (qt/qtdeclarative/6.3) ba7cc28ee5 (qt/qtdeclarative/6.4) 648eece174 (qt/tqtc-qtdeclarative/6.3) ba7cc28ee5 (qt/tqtc-qtdeclarative/6.4)

      Description

      Attached example tries to add a module with version 0.1 and MyType is not found in QML. If version is changed to >=1.0, then it works fine.

          qt6_add_qml_module(qtbug104373 URI "MyModule" VERSION 0.1 SOURCES mytype.cpp)
      

        Attachments

        For Gerrit Dashboard: QTBUG-104373
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            alexandru.croitor Alexandru Croitor
            Reporter:
            poikelin Joni Poikelin
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: