Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-104555

Top level builds broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Fixed
    • Affects Version/s: 6.4.0 Beta1, 6.5.0 FF
    • Fix Version/s: 6.5.0 Beta1
    • Component/s: Build System: CMake
    • Labels:
      None
    • Commits:
      83869e75d1db92b3e7416606fc06a02e3d17db4d

      Description

      When doing a top level configure they always fail with this error:

      CMake Error: AUTOMOC for target tst_qmltyperegistrar_major_version_zeroplugin: The "moc" executable "/home/carewolf/git/qt5/build-cmake/qtbase/libexec/moc" does not exist.

       

      Apparently trying to use moc, before it has been build. Configuring with -nomake example -nomake tests works around the problem.

        Attachments

        For Gerrit Dashboard: QTBUG-104555
        # Subject Branch Project Status CR V

          Activity

            People

            Assignee:
            qtbuildsystem Qt Build System Team
            Reporter:
            allan.jensen Allan Sandfeld Jensen
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes