Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-105542

Deprecate C++11/C++14 compatibility macros in documentation

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 6.4.0 RC1, 6.5.0 Beta1
    • Component/s: Core: Other
    • Labels:
      None
    • Commits:
      b057659255 (qt/qtbase/dev) b057659255 (qt/tqtc-qtbase/dev) 663e5259f5 (qt/qtbase/6.4) 663e5259f5 (qt/tqtc-qtbase/6.4)

      Description

      qcompilerdetection.h contains macros that were introduced to provide C+11/C14/C+17 compatibility in previous Qt versions. in Qt 6, they aren't necessary, and are just kept for compatibility. A comment in the header files says so:

      Compatibility macros for C++11/14 keywords and expressions.
      Don't use in new code and port away whenever you have a chance.
      

      Anyhow, the the documentation should also reflect the advice.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            kkohne Kai Köhne
            Reporter:
            kkohne Kai Köhne
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes