Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-107199

Update llvm for qttools

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • P1: Critical
    • Resolution: Fixed
    • None
    • None
    • None
    • 56a8d5a74 (6.4)
    • DaVinci 65, DaVinci 66, DaVinci 67, DaVinci 68

    Description

      We need to update the static llvm we link our Qt tools to a newer version.

       

      The LLVM version we currently provision in the CI is LLVM 12.0. This has issues with C++20 support (see QTBUG-107164). We should update at least to LLVM 13.0, but preferably to the latest LLVM version, which currently is LLVM 15.0).

      Attachments

        Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

              diseraluca Luca Di Sera
              kkohne Kai Köhne
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Gerrit Reviews

                  There is 1 open Gerrit change