Details
-
Bug
-
Resolution: Unresolved
-
P2: Important
-
None
-
6.5.0 FF
-
None
Description
For example see https://doc-snapshots.qt.io/qt6-dev/qml-coordinate.html
I want to declare a property of type coordinate. That doesn't work, but we have the registration
QML_VALUE_TYPE(geoCoordinate)
so it seems property geoCoordinate startCentroid actually works, as a place to stick a starting coordinate to be able to call alignCoordinateToPoint() later on.
I think putting a "geo" prefix on all the types is not so great. If you want to use a namespace, it's possible when you do the qml import. Wouldn't that be good enough to scope these generic type names?
https://doc-snapshots.qt.io/qt6-dev/qtpositioning-qmlmodule.html the capitalization is inconsistent, e.g. geocircle should be geoCircle according to the QML_VALUE_TYPE, etc.
Should make sure all the types are documented. I wonder what's the difference between geoPositionInfo and geoCoordinate and geoLocation... or maybe we should rather try to merge them, or maybe some are only internal?