Details
-
Suggestion
-
Resolution: Unresolved
-
P2: Important
-
None
-
7.0 (Next Major Release)
Description
QLCDNumber is one of the oldest classes in Qt – its roots go back to a BASIC program on the Sinclair Spectrum. While the widget provides valuable functionality, its name is misleading. Although Number implies that it only displays digits, in reality QLCDNumber can show a variety of characters (letters, spaces, colons, percent signs, minus signs, decimal points, etc.). Moreover, according to Qt’s CamelCase convention, the acronym should be written as Lcd (as seen in classes like QHttpServer, QUrl, QSsl, and others).
I propose renaming QLCDNumber to QDigitalDisplay. To ease the transition, QLCDNumber could be kept as an alias until Qt 7.0.
Additionally, the documentation should be updated to state that the widget “displays characters as a digital display would”, rather than implying it is limited to numbers.
Also, some method names could be improved:
- Rename checkOverflow() to isOverflow() to clearly indicate that it returns a Boolean value.
- Rename the display() slot to setValue() so that it aligns with slots in other QWidget-based widgets (such as QSlider and QProgressBar) that update their value.
In summary, renaming the class to QDigitalDisplay and updating its method names and documentation would more accurately reflect the widget’s full capabilities and align it with Qt’s naming conventions.