Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-12227

Remove dependency from GLU

    XMLWordPrintable

    Details

    • Type: Suggestion
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 4.7.0
    • Fix Version/s: 4.8.0
    • Component/s: GUI: OpenGL
    • Labels:
      None
    • Commits:
      c67b4cac2e53ae77c4e16487838c17be85e73aa3, ac6323c4346be5fb5b1111194b2ee98706a69ffa, 4e626903d0f6df00fa83c18061a12cb3a5dbd603

      Description

      Please remove dependency on OpenGL Utility library (GLU) or at least make it optional.
      GLU functions are not in OpenGL standard and as far as I can see - Qt never uses them.
      Particularly in major openSUSE distributions there are no GLU developer headers/libraries in distribution thus OpenGL configuration test always fails.
      Please remove dependency from GLU (or at least make it optional for X11/Desktop version).

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            bjnilsen Bjørn Erik Nilsen
            Reporter:
            dendy Daniel Levin
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes