Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-13807

compilation of qt: building libQtWebKit.so fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Duplicate
    • Affects Version/s: 4.7.0
    • Fix Version/s: None
    • Component/s: Other
    • Labels:
      None
    • Environment:

      Description

      Compilation of qt 4.7.0 fails:

      home/development/64-bit/qt-4.7.0/bin/moc -DQT_SHARED -DQT_EDITION=QT_EDITION_DESKTOP -DBUILDING_QT__=1 -DWTF_USE_ACCELERATED_COMPOSITING -DNDEBUG -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_USE_FAST_OPERATOR_PLUS -DQT_USE_FAST_CONCATENATION -DHAVE_STDINT_H -DBUILD_WEBKIT -DBUILDING_QT__ -DBUILDING_JavaScriptCore -DBUILDING_WTF -DENABLE_VIDEO=1 -DENABLE_JAVASCRIPT_DEBUGGER=1 -DENABLE_DATABASE=1 -DENABLE_EVENTSOURCE=1 -DENABLE_OFFLINE_WEB_APPLICATIONS=1 -DENABLE_DOM_STORAGE=1 -DENABLE_ICONDATABASE=1 -DENABLE_CHANNEL_MESSAGING=1 -DENABLE_ORIENTATION_EVENTS=0 -DENABLE_SQLITE=1 -DENABLE_DASHBOARD_SUPPORT=0 -DENABLE_FILTERS=1 -DENABLE_XPATH=1 -DENABLE_WCSS=0 -DENABLE_WML=0 -DENABLE_SHARED_WORKERS=1 -DENABLE_WORKERS=1 -DENABLE_XHTMLMP=0 -DENABLE_DATAGRID=0 -DENABLE_RUBY=1 -DENABLE_SANDBOX=1 -DENABLE_PROGRESS_TAG=1 -DENABLE_BLOB_SLICE=0 -DENABLE_3D_RENDERING=1 -DENABLE_SVG=1 -DENABLE_SVG_FONTS=1 -DENABLE_SVG_FOREIGN_OBJECT=1 -DENABLE_SVG_ANIMATION=1 -DENABLE_SVG_AS_IMAGE=1 -DENABLE_SVG_USE=1 -DENABLE_DATALIST=1 -DENABLE_TILED_BACKING_STORE=1 -DENABLE_NETSCAPE_PLUGIN_API=1 -DENABLE_WEB_SOCKETS=1 -DENABLE_XSLT=0 -DENABLE_QT_BEARER=1 -DENABLE_TOUCH_EVENTS=1 -DXP_UNIX -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../../../mkspecs/linux-g++-64 -I. -I../../../../include/QtCore -I../../../../include/QtNetwork -I../../../../include/QtGui -I../../../../include -Ibridge/qt -Ipage/qt -Iplatform/graphics/qt -Iplatform/network/qt -Iplatform/qt -I../WebKit/qt/Api -I../WebKit/qt/WebCoreSupport -I. -Iaccessibility -Ibindings/js -Ibridge -Ibridge/c -Ibridge/jsc -Icss -Idom -Idom/default -Iediting -Ihistory -Ihtml -Ihtml/canvas -Iinspector -Iloader -Iloader/appcache -Iloader/archive -Iloader/icon -Inotifications -Ipage -Ipage/animation -Iplatform -Iplatform/animation -Iplatform/graphics -Iplatform/graphics/filters -Iplatform/graphics/transforms -Iplatform/image-decoders -Iplatform/mock -Iplatform/network -Iplatform/sql -Iplatform/text -Iplugins -Irendering -Irendering/style -Istorage -Isvg -Isvg/animation -Isvg/graphics -Isvg/graphics/filters -Iwebsockets -Iwml -Iworkers -Ixml -Igenerated -I../JavaScriptCore -I../../webkit -I../JavaScriptCore/assembler -I../JavaScriptCore/bytecode -I../JavaScriptCore/bytecompiler -I../JavaScriptCore/debugger -I../JavaScriptCore/interpreter -I../JavaScriptCore/jit -I../JavaScriptCore/parser -I../JavaScriptCore/pcre -I../JavaScriptCore/profiler -I../JavaScriptCore/runtime -I../JavaScriptCore/wtf -I../JavaScriptCore/wtf/symbian -I../JavaScriptCore/wtf/unicode -I../JavaScriptCore/yarr -I../JavaScriptCore/API -I../JavaScriptCore/ForwardingHeaders -I../JavaScriptCore/generated -I../include/QtWebKit -I../../../../include/QtWebKit -I.rcc/release-shared -I../../../../include/phonon -I/usr/X11R6/include -I.moc/release-shared ../WebKit/qt/Api/qwebinspector.h -o .moc/release-shared/moc_qwebinspector.cpp
      /home/development/64-bit/qt-4.7.0/bin/rcc -name WebCore WebCore.qrc -o .rcc/release-shared/qrc_WebCore.cpp
      /home/development/64-bit/qt-4.7.0/bin/rcc -name WebKit inspector/front-end/WebKit.qrc -o .rcc/release-shared/qrc_WebKit.cpp
      make[1]: *** Er is geen regel om doel '../JavaScriptCore/release/libjscore.a' te maken, nodig voor '../../../../lib/libQtWebKit.so.4.7.0'. Gestopt.
      make[1]: *** Wachten op onvoltooide taken...
      make[1]: Map '/home/development/64-bit/qt-4.7.0/src/3rdparty/webkit/WebCore' wordt verlaten
      make: *** [sub-webkit-install_subtargets-ordered] Fout 2
      

      (i.e. the errors is: "No rule to make target '../JavaScriptCore/release/libjscore.a', needed by '../../../../lib/libQtWebKit.so.4.7.0'").

      After above error, one can do the following:

      cd qt-4.7.0/src/3rdparty/webkit/JavaScriptCore/
      make
      cd -
      make
      

      and after this compilation finishes successfully. Note that this is not very new - we have this stream of commands (make; cd to JavaScriptCore; make; cd -; make) as part of our qt compilation scripts for a while now...

      We configure using:

       ./configure \
       -release -commercial \
       -qvfb \
       -prefix $QTDIR/install \
       -system-sqlite -I$SQLITEDIR/include -L$SQLITEDIR/lib -lsqlite3 \
       -qt-sql-psql -I$PGDIR/include -I$PGDIR/include/server -L$PGDIR/lib -lpq \
       -cups \
       -dbus \
       -phonon \
       -v
      

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            buddenha Oswald Buddenhagen
            Reporter:
            wiecko Marek Wieckowski
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes