Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-15819

The first image painted to PDF is invisible when brush color of the QPainter is set to Qt::transparent

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Out of scope
    • Affects Version/s: 4.7.0, 4.7.1
    • Fix Version/s: 4.8.x
    • Labels:
      None
    • Environment:
      I have tested the bug on Linux and Windows.

      Description

      The first image that I printed to PDF file becomes invisible. When I print a copy of the same image to the same PDF file, it becomes visible. So the problem is only for the first copy of the image, when I paint the the same image second time or third time there is no problem.(These are not the same QPixmap objects. These are different QPixmap objects which are created from the same image file.) After painting an image, if I paint a different image for the first time, it also appears invisible.
      Later, I've realised that this problem only occurs when I set the brush color of the QPainter to Qt:transparent before I call QPainter::drawPixmap(). This problem only occurs when I print to PDF file. I have attached a sample main.cpp that triggers the bug.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              johnlayt John Layt
              Reporter:
              feoran Mustafa Cavus
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes