Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-16067

Display issues while using OpenVG and native Symbian camera api.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Out of scope
    • Affects Version/s: 4.6.3
    • Fix Version/s: None
    • Component/s: (Inactive) OpenVG
    • Labels:
      None
    • Environment:
      QT version:
      4.6.3, 4.7.1

      QT apis affected:
      QPainter

      Device:
      N8 RM-596

      Rom version:
      011.012.00.01 2010-09-18

      Description

      Details:
      The screen is not properly refreshed if camera is initialized and multiple updates are requested.
      It seems like surface painting is affected (vector painting always work as expected).

      Workaround:
      Switch to any other display mode (i.e. call QApplication::setGraphicsSystem(QString("raster"))).

      Expected result:
      Two pictures displyed interchangable over the time (see TestApp)

      Result:
      One picture displayed properly, second frame not displayed at all.

      Repro:
      5/10. If not reproducing pls try restarting phone - actually it is 0/10 or 9/10.

      TestApp:
      Test app pre loads two images and displays them on the screen interchangable. The pictures are swapped each 50 displays (so first frame is displeyd 50 times than second than first etc.)
      Update is called at the end of each paint method.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            jhautaka Jani Hautakangas
            Reporter:
            blstream BLStream.com
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes