Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-21906

Expose an API to enable and disable SSL compression support

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 4.8.0, 5.0.0
    • Component/s: Network: SSL
    • Labels:
      None
    • Environment:

      Any recent openssl

    • Commits:
      4.8: 19bd31fc84cc4916aef4835429fc4a55e85d0c28, 5.0: 78d02e93aca5325fc5be9bfd275862795207abaa

      Description

      There is no API for enabling or disabling compression which is required to connect to some buggy servers (eg. the on KDE bug 275524 [bugs.kde.org] ) there are probably other servers as broken as this one around. Only newish openssl's support this which means that we'll probably hit an increasing number of such problems.

      We can use SSL_OP_NO_COMPRESSION to provide this facility.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            phartman Peter Hartmann (closed Nokia identity) (Inactive)
            Reporter:
            richmoore Richard Moore (qtnetwork)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes