Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-20885 Larger changes for Qt 5
  3. QTBUG-23525

Deprecated API should be wrapped with QT_DEPRECATED_SINCE

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Not Evaluated
    • Resolution: Done
    • Fix Version/s: 5.0.0
    • Component/s: None
    • Labels:
      None
    • Technical Risk:
      Normal
    • Commits:
      If881821ae095f054b31cc13464f19e2007c20ed7

      Description

      API which is newly deprecated in Qt 5.0 is mostly covered with QT_DEPRECATED_SINCE and inlined so that it can be compiled out.

      However, API which was deprecated during the Qt 4 cycle is mostly not wrapped in QT_DEPRECATED_SINCE. Mostly it is covered by QT_DEPRECATED, but not always. Sometimes it is only marked with \obsolete in the documentation (eg QAbstractItemDelegate::elidedText).

      All examples of both of those cases should be found and fixed.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            laknoll Lars Knoll
            Reporter:
            stephen.kelly Stephen Kelly (Unused account) (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes