Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-23999

Qt should build with QT_DEPRECATED_SINCE(5, 0) defined

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 5.0.0 Beta 2, 5.0.0
    • Component/s: Other
    • Labels:
      None
    • Technical Risk:
      Normal

      Description

      Currently Qt uses some of its own deprecated API. It should probably be ported to non-deprecated API after feature freeze.

      QT_DISABLE_DEPRECATED_BEFORE shoudd be defined to 5.0

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            stephen.kelly Stephen Kelly (Unused account) (Inactive)
            Reporter:
            stephen.kelly Stephen Kelly (Unused account) (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes