Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-25190

xcb dependencies README location is incorrect from configure script

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 5.0.0 Beta 1
    • Fix Version/s: 5.0.0 Beta 1
    • Component/s: Build System
    • Labels:
      None
    • Environment:
      Linux
    • Commits:
      c2543dc358912663285eac56b792eee9fa2a3364

      Description

      If xcb dependencies are missing, the configure script ends with this:

      No QPA platform plugin enabled!
      If you really want to build without a QPA platform plugin you must pass
      -no-xcb and -no-eglfs to configure. Doing this will
      produce a Qt that cannot run GUI applications.
      The dependencies needed for xcb to build are listed in
      src/plugins/platforms/xcb/README

      However the README location is
      qtbase/src/plugins/platforms/xcb/README

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              buddenha Oswald Buddenhagen
              Reporter:
              pnoffke Patrick Noffke
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes