Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-26636

Examples do not run for static build of Qt

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Duplicate
    • Affects Version/s: 5.0.0 Beta 1
    • Fix Version/s: 5.0.0 Beta 1
    • Component/s: Core: Plugins
    • Labels:
      None
    • Environment:
      * OS : Ubuntu 10.04, Ubuntu 12.04
      * Build type: shadow build
      * Configure line:
      {quote}
      configure -static -opensource -confirm-license -silent -prefix $PWD/qtbase
      {quote}

      Description

      Ran the command:

      ./qtbase/examples/widgets/wiggly/wiggly

      And saw the error:

      Failed to load platform plugin "xcb". Available platforms are:

      Aborted

      This issue occurred for any example application I tried

      In the build I see:
      ./qtbase/plugins/platforms/libxcb.a

      I suspect that the plugin loading logic is not correct for static builds ATM.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              isdale Keith Isdale (closed Nokia identity) (Inactive)
              Reporter:
              isdale Keith Isdale (closed Nokia identity) (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes