Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-27114

Qt5 Beta1,Cannot build on none OpenGL support board

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Duplicate
    • Affects Version/s: 5.0.0 Beta 1
    • Fix Version/s: None
    • Component/s: Build System
    • Labels:
      None

      Description

      Heres my configure script:

      ./configure --prefix=/home/qwl/th-3716m/pub/ -release -opensource -confirm-license -shared -xplatform linux-arm-gnueabi-g++ -platform linux-g++ -lrt -no-cups -no-gtkstyle -nomake examples -nomake demos -L/home/qwl/th-3716m/pub/lib -no-iconv -openssl -I/home/qwl/th-3716m/pub/include/ -no-neon -no-opengl -directfb -qpa -verbose -v -no-egl

      But when building QT5,it still add the OPENGL libs:

      cannot find -lGL

      So,i fixed all the Makefile(widgets,printsupport,plugins/imageformats,plugins/platforms,plugins/generic,qtsvg/src/svg,qtsvg/src/plugins/iconengines/svgiconengine,qtsvg/src/plugins/imageformats/svg,) that add the wrong GL libs.

      QT5 build failed @ qtdeclarative/src/quick/util/qquickpixmapcache.cpp

      It seems needs OPENGL...

      Is QT5 only support chips with OPENGL??

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              rodal Samuel Rødal
              Reporter:
              qwl kellenqian
              Votes:
              0 Vote for this issue
              Watchers:
              18 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes