Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-27469

WebKit appears to drop the last 512 bytes from a QNetworkReply (custom protocol) implementation.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Invalid
    • Affects Version/s: 4.8.3, 5.3.0
    • Fix Version/s: None
    • Component/s: WebKit
    • Labels:
      None
    • Environment:
      MSVC2010,Qt4.8.3,64-bit build,CUDA,Windows7SP1. Also affects Linux with qt4.8 and qt5 dev branch

      Description

      I implement a custom protocol (using the same method I used successfully in a Qt4.7.x release previously) using QNetworkReply, QNetworkAccessManager and a subclassed QWebView. It returns e.g. some file from a resource. However, in Qt4.8.3 WebKit appears skip the last 512 bytes of this QNetworkReply. If I pad the reply with 512 bytes of 0, then HTML and image content render properly. *This may be related to QTBUG-24110.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            allan.jensen Allan Sandfeld Jensen
            Reporter:
            tdewolf Timothy DeWolf
            Votes:
            2 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes