Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-30736

hybrid QImage and QPixmap in QtWebKit Bridge broken with Visual Studio 2010 Release Mode

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.0.1, 5.0.2, 5.1.0 Beta 1
    • Fix Version/s: 5.3.1
    • Component/s: WebKit
    • Labels:
      None
    • Environment:
      Visual Studio 2010 SP1 Ultimate, Windows SDK 7.0a, MinGW 4.7.1
    • Commits:
      43d40815e5ed44a3dbc89380ae4b8975c4f86cb7

      Description

      There seems to be a problem with the code in the WebKit bridge. Sharing a QImage or a QPixmap works as expected on Mac OS X, Linux and Windows in Debug mode. However, on Windows in Release mode the code throws an exception in QtWebKit. As its nearly impossible to debug I build a small test system:

      https://github.com/seichter/sandbox/tree/master/bugreports/qt5-qtwebkit

      What you can observe is that the object is complete, the method is available, however, the call will end in an exception. My guess is that in Release mode parts of the code in the bridge are optimized away because the exact same method works as expected on other platforms (gcc, clang) and in Debug mode.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            allan.jensen Allan Sandfeld Jensen
            Reporter:
            seichter Hartmut Seichter
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes