Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-30907

Some icons are not displayed in QTreeView and QTableView when using QFileSystemModel

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Done
    • Affects Version/s: 5.0.0, 5.0.1, 5.0.2
    • Fix Version/s: 5.1.0 Beta 1
    • Component/s: Core: I/O, GUI: Painting
    • Labels:
      None
    • Environment:
      OS X 10.7 and 10.8, Xcode 4.6.2 (Build version 4H1003)
    • Commits:
      c90486066914d7c63716c12f6e2f1c8086f0eb37

      Description

      When using QFileSystemModel as model for QTreeView and QTableView the some icons for files and folders are empty. The missing icons are totally random.
      This is most noticeable when you expand a node (folder) in QTreeView.
      This occurs even with the simplest application that has only QTreeView and QFileSystemModel. The file/folder permissions are correct.
      The problem occurs more often on slower machines.

      TestIconDisplay.zip is a sample project with both QTreeView and QTableView, and TreeViewTest.zip is a sample project that only has QTreeView.

        Attachments

        1. sc1.png
          sc1.png
          88 kB
        2. sc2.png
          sc2.png
          103 kB
        3. sc3.png
          sc3.png
          56 kB
        4. TestIconDisplay.zip
          4 kB
        5. TreeViewTest.zip
          2 kB
        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            dedietri Gabriel de Dietrich (drgvond)
            Reporter:
            toptan Toplica Tanasković
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes