Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-31690

Qml2Puppet for Qt Quick Designer crashing in the latest 5.1 packages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.1.0 Beta 1
    • Fix Version/s: None
    • Component/s: Quick: Other
    • Labels:
      None
    • Environment:
      Mac OS X

      Description

      Qml2Puppet for Qt Quick Designer crashing in the latest 5.1 packages.

      There are two reasons:

      (1) There is no qml2puppet in the Qt 5.1 coming with the SDK
      (2) The fallback qml2puppet in Qt Creator is missing the import for Qt Quick 2

      Both 1 and 2 are regressions while (2) is a regression from the packages from yesterday.

      (1) qmlpuppet for Qt Quick 1 is also affected.

      (2) Qt Creator.app/Contents/imports is missing the qtquick2 directory containing the required imports.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              kkohne Kai Köhne
              Reporter:
              thohartm Thomas Hartmann
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes