Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-32018

Can't get portName & productIdentifier

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.0.0
    • Fix Version/s: None
    • Component/s: Serial Port
    • Labels:
      None
    • Environment:
      Microsoft Windows 7 Service Pack 1
      wingw4.7
      Qt 5.0.2 opensource

      Description

      I've built QtSerialPort as it was suggested here
      https://bugreports.qt-project.org/browse/QTPLAYGROUND-26
      only I've used strawberry perl.

      The simplest program which should print available serial ports information gives me wrong output.
      The code is following
      foreach(QSerialPortInfo q, QSerialPortInfo::availablePorts()) {
      qDebug() << q.portName() << " " << q.productIdentifier() << " " << q.vendorIdentifier();
      }

      and the output was
      "COM3" 0 0
      "COM9" 0 0
      "COM8" 0 0
      "COM7" 0 0
      "COM10" 0 0
      "COM11" 0 0
      "COM4" 0 0

      but when I watch hardware ID's from device manager for COM3 it was PCI\VEN_8086&DEV_3B67&SUBSYS_172B103C&REV_06
      so the output should be at last
      "COM3" 0x3Bb67 0x8086

      hasProductIdentifier() & hasVendorIdentifier() also give me false.

      using official qt-windows-opensource-5.0.2-mingw47_32-x86-offline on win7 sp1.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            lpapp Laszlo Papp
            Reporter:
            shh Hayk Shahparonyan
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Gerrit Reviews

                There are no open Gerrit changes