Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-32248

Updating Qt component with MaintenanceTool/Updater will cause error

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1: Critical
    • Resolution: Done
    • Affects Version/s: 5.1.0
    • Fix Version/s: 5.1.1
    • Component/s: Packaging & Installer
    • Labels:
      None
    • Environment:
      All platforms
    • Commits:
      13eee1217d8893f0890cca44192d615ccbafcc86

      Description

      User has existing installation of online Qt 5.1.0.
      When using MaintenanceTool to fetch update 5.1.0-1 will cause sdkTool
      error as it tries to register the Qt version again in QtCreator.

      The installer should first uninstall the previous registration before attempting a new one (update).

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              kkohne Kai Köhne
              Reporter:
              iknd Iikka Eklund
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes