Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-34364

QSystemtrayicon doesn't show icon with example built with 5.1.1 but does when built with 5.0.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P3: Somewhat important
    • Resolution: Duplicate
    • Affects Version/s: 5.1.0 , 5.1.1, 5.2.0 Beta1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      intel i5, 16gb, win 8 running various 'lini' inside virtualbox.

      Description

      I'm suffering this too. In 5.2 beta i get no systray icons. Built with 5.0.0 they're fine in mint cinnamon or mate.

      just gone back through qt versions to regression test. The change happens between 5.0.2 and 5.1.0 if that's any help tracking down the source.

      also when running mint cinnamon, if you turn on 'looking glass mode' when running against 5.1.1 you get the following message in the errors tab which i think sheds a little light on it....

      Adding systray: <application name> (1x1px).

      Sure enough if you can find the exact pixel and right click it you can get the context menu to appear.

      Against 5.0.2 it shows a different message:
      Adding systray: unknown (22x22px)

      so it appears it adds a single pixel item to the tray in 5.1.0 and above.

      Hope that's some use,

      Rich

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              jolind Jorgen Lind
              Reporter:
              wagnered Ernest Wagner
              Votes:
              10 Vote for this issue
              Watchers:
              17 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Gerrit Reviews

                  There are no open Gerrit changes