Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-34908

[Windows/XCB (KDE)] Not all characters are not showing correctly (depending on installed fonts)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reported
    • Priority: P3: Somewhat important
    • Resolution: Unresolved
    • Affects Version/s: 5.1.1
    • Fix Version/s: 5.2.1
    • Component/s: GUI: Font handling
    • Labels:
      None
    • Environment:
      Windows 8, XCB (KDE)
    • Commits:
      Windows: 409488f3e3485c58eedfa81a92d66042e7c7b462 (stable , 5.2.1)

      Description

      Use example: qtbase\examples\widgets\richtext\textedit
      Apply to the example following string: "ತಎತ and ヽ༼ຈل͜ຈ༽ノ"
      First three characters are not shown correctly in Windows 8. In Windows 7 everything shows fine.

        Attachments

        1. qtbug34908_4_windows.log
          12 kB
        2. qtbug34908_4_x11.log
          113 kB
        3. qtbug34908_5_windows_ft.log
          210 kB
        4. qtbug34908_5_windows.log
          271 kB
        5. qtbug34908_5_x11.log
          77 kB
        6. qtbug34908_diag_4.patch
          17 kB
        7. qtbug34908_diag_5.patch
          23 kB
        8. qtbug34908_simple.zip
          1 kB
        9. qtbug34908.zip
          2 kB
        10. textdumper.zip
          2 kB
        11. unicode problems.png
          unicode problems.png
          225 kB

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              esabraha Eskil Abrahamsen Blomfeldt
              Reporter:
              qtcomsupport Qt Support
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:

                  Gerrit Reviews

                  There are no open Gerrit changes