Uploaded image for project: 'Qt'
  1. Qt
  2. QTBUG-34949

Can't build Qt with desktop OpenGL and EGL

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P2: Important
    • Resolution: Done
    • Affects Version/s: 5.2.0 Beta1
    • Fix Version/s: 5.2.0 RC1
    • Component/s: GUI: OpenGL
    • Labels:
      None
    • Environment:
      Ubuntu Linux, Mesa, EGL
    • Commits:
      95ffd606f8a632a8a963486ce340e7e1b707be0a

      Description

      Qt 5.2 can no longer be build with desktop openGL and EGL. This was possible in Qt 5.0.

      I've done a ugly patch which basically bypasses the check on configure and stuff compiles correctly, so I do not understand why the check was added.

      This regression is making it hard for us to work on Mir + Qt integration.

      Ugly patch attached

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              tsdgeos_canonical Albert Astals Cid (Canonical) (Inactive)
              Reporter:
              tsdgeos_canonical Albert Astals Cid (Canonical) (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Gerrit Reviews

                There are no open Gerrit changes